
IʼVE SHOT MY FIRST STEREO 3D PROJECT... NOW WHAT?!

So, where to begin? Well, you begin by shooting the footage perfectly in the first place. The old saying, ʻAn 
ounce of prevention is worth a pound of cureʼ applies perfectly here. But if you havenʼt shot it perfectly, 
Make3D has plenty of widgets to help you adjust it until it looks perfect for your final output, and Sony Vegas 
Pro has all the horsepower to make things run smoothly while you edit and composite simultaneously!

Be sure to have installed the latest version of Vegas Pro Non-Linear Editing software from Sony Creative 
Software, and then download and install the latest version of Medtron Make3D, made exclusively for Sony 
Vegas Pro.

Medtron uses image analysis to help you roughly line up horizon and zoom levels, and was designed to use 
the ample resolution of HDV or Full HD frame sources, so you must be shooting High Definition video, but 
who isnʼt these days? Capture/Import your HD footage into separate folders on any hard drive you have 
connected to your system. (Separate them according to whether they are left eye or right eye camera files) 
Be sure that each video stream has the same number (and approximate location) of scene breaks, if any, or 
there will be no way for Make3D to create a match. 

Create an empty project folder on your working drive (the fastest non-system drive you have available, or a 
RAID volume). Put nothing in this project folder; Make3D will put everything there for you. 

Create a new project within Sony Vegas Pro 
and adjust your project properties by selecting 
the Full HD preset which most closely 
resembles the media youʼre using (1080 60i/
24p). While itʼs not absolutely necessary to 
process your 3D video with 32 bit floating 
point color handling, it is certainly 
recommended, especially if you know that 
youʼll need to make color correction/grading 
adjustments later on. 

(On the audio tab I prefer 5.1 surround as it 
creates a more immersive experience overall, 
but Make3D is designed to work with two 
stereo tracks.)

Ok, youʼre ready to invoke Make3D from the 
drop-down menu by going to Tools -> 
Extensions -> Make3D.

Ok, take a deep breath; there are a lot of 
fields on the first Make3D dialog box and you may feel a little overwhelmed, but latter steps are not clickable 
until you have completed the first basic tasks, so youʼll be just fine :)
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http://www.sonycreativesoftware.com/vegaspro
http://medtron.org/make3d_trial.aspx
http://medtron.org/make3d_trial.aspx


The first area of the dialog box is 
named ʻSelect Video Directory and 
Extensionsʼ. 

Straightforward enough; (this is the 
part where having a very fast RAID 
comes in handy) the ancillary .txt files 
that Make3D uses to store your 
evolving scripts are stored in this 
directory right alongside temporary 
media and render files. It may seem 
like a mess, but do not touch/
rearrange anything inside of this 
folder; if you just follow the steps as 
outlined Make3D will clean it all up 
for you when you are all done.

Youʼll notice that you can also 
change the video extension. Despite 
Vegasʼ well-documented ability to 
edit everything and the kitchen sink, 
Make3D does NOT like using mixed 

media formats in the same project. 
Besides, you would never be shooting 
stereo 3D with two different types of 

cameras anyway.

Next is the Import Video area. Make3D needs to make some folders inside of your working directory, and 
(for some reason I donʼt fully understand) requires you to press the ʻCreate Directoriesʼ button. It seems to 
me that this could be automated in the future, but whatever; it just works! 

Now you will import your media into the project. You are required to transfer the video one subdirectory at a 
time. After pressing the import LEFT videos button, Make3D will ask you if youʼve established a link with the 
LEFT camera; we as an industry are moving towards IT based workflows, so the idea is that you will have 

just come back from a shoot and not transferred any 
media to your hard drive yet. Of course, if you are 
shooting HDV, you will need to capture to a LEFT and 
RIGHT scratch folder. Once youʼve established a link with 
the camera (or scratch folder) and browsed to the location 
of your media there will be a long pause. Make3D will 
appear unresponsive during this time. Donʼt freak out, and 
donʼt do anything while this is taking place. Just get a 
drink of water, get a snack or use the restroom, and wash 
your hands. By the time you get back, Make3D will be 
ready for you to import RIGHT videos. Repeat restroom/

snack break.

When the video is all done transferring, you will see the option to ʻCreate L R Dataʼ click this button, and wait 
a moment while Make3D begins to write .txt files describing the relationship between the different streams. 
Last in this area is ʻVerify video pairs.ʼ Click it to be sure that file size and length match up properly. 



Ok, so this last section is where the process actually starts to get fun! Synchronize and Align Video Pairs!!! 
The magic of 3D all happens in this delicate process, so pay close attention. The first button will renumber 
the videos so that Make3D can more easily write scripts in the background. Same with wave file creation 
(the following button). The ʻFind Clicksʼ button will open an interesting looking dialog like this:

Youʼll notice the green vertical bars and two audio channels. Nothing will populate those spaces until you 
click on a video pair from 
below.

Once youʼve selected a video 
pair, youʼll see the dialog 
change:

Make3D is basically looking 
for the sound of a clapper 
board or clicker in each audio 
stream, but you can help it by 
manually placing the audio 
sync point.

Once youʼve found sync, 
press ʻWriteʼ, and select any 
other clips in the ʻInput Video 
Pairsʼ bin. Repeat as needed.

Next youʼll create jpg pairs. 
Why? To help you achieve 
proper visual alignment. Click 
ʻCreate JPG Filesʼ, wait a 
moment as theyʼre generated, 
and then click ʻFind 
Alignmentʼ. This will pop up:
Didnʼt I tell you? This is the 
fun part! There are all sorts of 
controls to ensure a proper 

visual alignment between your two video streams here, though will use two jpegs as proxies for now. As for 
me, I prefer to zoom in and use RED/CYAN anaglyph preview like this:
And sometimes it just helps to shift back and forth between multiple views and zoom levels. 



Now to the left of this dialog youʼll see two very squozen images side by side, this is to emphasize vertical 
alignment. Vertical alignment is a deal-breaker in stereo 3D; most viewersʼ eyes will adjust to an incorrect 

horizontal shift, but not a vertical shift. It causes nausea faster than anything else you could do here, so use 
this sidebar to full advantage. When youʼre done, click ʻWrite Alignmentʼ and youʼll see the video pair you 
just worked on move over to the ʻProcessed Video Pairsʼ bin. When youʼre done click ʻExitʼ

You will be brought back to the main Make3D window. Click ʻCreate New 3D Timelineʼ and you will see the 
following warning:

Well, unless you already have a project on the timeline, OF COURSE you want to continue! Click ʻOKʼ and 
youʼll be greeted by the following options:



Click on the individual video pairs you want to add to your 
new 3D timeline, or alternately you may click ʻAdd All Input 
to Outputʼ to simply dump everything onto your timeline. 
And select the 3D format you wish to work in. This setting 
can be changed later for final output, so you should 
choose whatever option is best for you and your hardware. 

For example: 
Anaglyphs require 
two additional video 
tracks to do an 
additive composite of 
each color, and so will 
require faster hard 
drives and processor 
speed. Dual stream 
uses two additional 
video tracks but only 
composites white to 
each track, and is 
less processor 
intensive. Side by 
Side of course 
requires only the two 
video tracks for your 
video pairs, and is 
very speedy on most 
systems, but requires 
that you edit cross-
eyed. So choose 
accordingly, but know 
that it can be 
changed at any point 
during your edit, 
without posing any 
threat to the various 
3D adjustments 
youʼve made. Click on ʻAdd Output to Timelineʼ and you will finally get to see this familiar sight:

The Vegas Pro timeline! And pre-configured for your desired 3D options no less. Now all we have to do is fix 
any problems -too easy!

Youʼll notice in the above picture that my subject is behind the zero point on the z-plane. Letʼs just say, for a 
moment, that I meant to shoot the footage with my subject at zero depth, so that when ever he moves his 
arms towards the camera, they ʻpop outʼ, giving the classic 3D illusion of depth protruding from the screen. 



Weʼll fix this in no time. first weʼll select the clip we wish to re-adjust, then select Make3D from the Tools-
>Extensions menu. From the Make3D window, press ʻAdjust 3D pan cropʼ. You will be treated to a whole 
new adjustment window, with even more adjustment parameters than the preliminary alignment tool (see 
below left).

This tool includes not only alignment but also zoom control so you can correct frame size/output aspect, as 
well as complete flip control so you can invert images youʼve obtained with a lens adapter or by mounting 
your L or R cam upside down (this is a fairly common practice when trying to achieve narrow inter-ocular 
distance with consumer HDV camcorders). Even more importantly, this tool allows for key-framable 
adjustments, if only at the start and end of each 3D event. This can easily be worked around by using one of 
the other tools in the Tools->Extensions toolbox: Make3D Split. 
This is similar to the standard Vegas Pro ʻsplit at cursorʼ (S) command with one critical difference: it writes all 
the changes that you see in your timeline to the Make3D scripts being made behind the scenes (so that 
Make3D can in turn talk to Vegas Pro and handle all of the pan/crop/zoom keyframes on a per-event basis, 
instead of letting you chop your key-framed events willy-nilly).

If you use the Make3D Split tool in leu of using pan/crop/zoom keyframes, as opposed to a mere “create edit 
point here” tool, then the Make3D workflow becomes a lot more useable.



For example, as an exercise 
in 3D convergence 
adjustment, I decided to keep 
my subject at zero-depth for 
the duration of the sequence. 
However, the subject is a 5 
year old boy, hardly able to 
keep still for very long, and so 
I was forced to make 
convergence adjustments 
every 3 seconds or so. 
(Perhaps in the near future 
someone will create an open-
source stereo image analysis 
tool to automate this process 
so that we can do camera 
stabilization and convergence 
stabilization simultaneously) 
This effort required that I look 
to see when the subject was 
moving forward or backward, 
and create Make3D Split 
points where I would normally 

place keyframes, then open up the Adjust 3D Pan Crop tool and toggle 
between the ʻStartʼ and ʻEndʼ points of each event by clicking ʻ<<Cursor/
Cursor>>ʼ and ʻ<<Event/Event>>ʼ. 

Needless to say, this took a minute or two, but I finished up with a result I can 
live with. (See right vs. previous page)

 

So thatʼs basically how you 
use Make3D to work with 
media on the timeline (in a 
nutshell) except for the last 
tool: Make3D Delete. This 
should be apparent as far 
as itʼs function, but itʼs 
proper use probably not so 
much. Make3D Delete 
requires that you have the 
entire grouping of clips that 
form a 3D event selected, 
as you see below. 
Otherwise, it will not know 



what part of the timeline you wish to delete. And you should use the Make3D Delete instead of the Vegas 
Pro selection edit tool or ripple delete to keep your scripts working properly. Simple.

Now comes the final render. The moment of truth. Ok, so 
which format? What frame size/resolution? What encoding 
settings? Patience, young grasshopper! First you must 
color correct and color grade. Click on Tools->Extensions-
>Make3D and press the Convert Timeline 3D Format. You 
will be presented with as many options as before, but the 
ideal way to color correct and color grade 3D, in my 
humble opinion, is side-by-side.

Make whatever adjustments necessary to your media, and 
be sure to copy and paste color adjustment/curves 
keyframes from one eye to the other (unless you have a 
horrific color imbalance between the two eyes). Do not, 
however, blindly copy and paste attributes by right clicking 
one event, selecting copy, and right clicking the other event 
to select ʻpaste attributesʼ; you will also paste pan/crop/
zoom data and undo the many hours, days, weeks, or 
months of work you have put in to your project. Got it? It 
bears repeating:

DO NOT COPY AND ʻPASTE ATTRIBUTESʼ, AS YOU 
WILL DESTROY ALL PAN/CROP/ZOOM DATA!

Now, assuming your color adjustments are done, we will convert the timeline back to your desired output 
format and render your project. There are many options, and it is entirely up to you and your intended 
audience. (It is worth noting, however, that the Blu-ray Disc Association has not yet released official specs 
for delivering 3D content on the Blu-ray Disc platform as of this writing, but they will soon. So, be prepared 
for a follow up article on prepping your content for distribution on Blu-ray Disc using Sony Creative 
Softwareʼs excellent line of BD authoring tools.) Now you will render using Make3D as well, which is 
important because if you want to render two separate video streams for someone else  (i.e.; your distribution 
partner) to re-format later, then this will be the fastest way to start a batch render process. Click on Tools-
>Extensions->Make3D then press the ʻRender 
Timelineʼ button. Youʼll see this window:

Some of the options will be grayed out 
depending on which 3D format youʼre using.
Itʼs nice to have options; in this case, the major 
options are web formats, archive formats, and 
deliverable formats. DVD & Blu-ray templates 
are a mouse click away, as are HDV, should 
you choose to prep your project for rendering 
back to tape as an archive. At any rate, you 
know what you need, and this is the simplest 
way to get it.

If youʼve finished working with your project and 
you want to free up HDD space by getting rid 
of the copied files that Make3D has made for 
you, go to Tools->Extensions->Make3D, and 
click ʻCleanup Directoryʼ. Your media, .txt files, 
and temp renders will all be permanently 



deleted. Be sure not to click this button accidentally, as thereʼs no going back.

The majority of the work in 3D is ensuring a non-vomit-comet ride by fixing alignment (pan/crop/zoom) So 
ʻeditingʼ for a 3D project when using the Make3D extension of Sony Vegas Pro consists of splits and 
deletions, directly on the timeline no less. “But what about my star wipes?!” you ask indignantly. Well, editing 
theory for 3D is a topic for a whole different tutorial altogether. The real work is, again, in maintaining a 
visually stimulating/pleasant convergence point to keep your audience engaged. Keep it to hard cuts only 
while you learn how to tell stories in the 3rd dimension and, who knows? Maybe youʼll decide you didnʼt 
need all those star-wipes in the first place.

-Seth Estrada
10-15-2009


